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ABSTRACT 
The success of an emergency response project is that it can be completed 

quickly and on time because of the urgency of the situation so that timely management 

of implementation is needed by making a schedule. This research was conducted to 

determine the appropriate scheduling method according to the character of the 

emergency response construction project. Scheduling methods are used in the form of 

Critical Path Method (CPM) and Precedence Diagram Method (PDM). The analysis 

was carried out on the duration and dependencies for each work item which was then 

scheduled with the help of Microsoft Project 2019 to get the results in the form of 

network diagrams and critical paths. Based on the results of the scheduling analysis the 

Replacement Project of Salim River Bridge Mataraman, it was found that for the CPM 

method the project could be carried out for 129 days starting from January 20, 2021 and 

ending on May 29, 2021 and for the PDM method the project was carried out for 120 

days starting from January 20, 2020 and ends on May 20, 2021 earlier than the CPM 

method. Each method has two critical paths due to the traffic safety and management 

work required throughout the project. 

Keywords : Critical Path Method (CPM), Precedence Diagram Method (PDM), 

Microsoft Project 2019 
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1. INTRODUCTION 

Emergency response construction projects are projects based on circumstances 

caused by natural disasters in accordance with legislation. Which results in damage to 

infrastructure that interferes with public service activities and/or endangers the 

community. This project is called an emergency response project because it is one of the 

main bridges located on the national road connecting the provinces of East Kalimantan 

and South Kalimantan where on January 17, 2021, there was a landslide and caused the 

bridge to break due to the flood disaster. As a result of this incident, the route which is 

the national road cannot be passed so that community activities are hampered, therefore 

this project is said to be an emergency response because of the urgency of the situation 

so that it cannot be delayed in handling so that timely management of implementation is 

needed, in this case it can be done by create a project schedule. A scheduling method 

that is easy to understand and fast to work on is needed to avoid delays in project work. 

The CPM and PDM methods were chosen because so far the scheduling used in the 

project only uses the S curve which in its use is difficult to control the course of the 

project so that scheduling is made with the CPM and PDM methods which can analyze 

the relationship of activities according to needs, namely by making work diagrams and 

knowing critical path. In addition, these two methods were also chosen because of the 

use of Microsoft Project 2019 which has the facility to schedule the two methods. This 

research was conducted to be able to perform scheduling using the CPM and PDM 

methods with Microsoft Project 2019 and to compare the duration and critical path of 

the two methods. 

 

2. LITERATURE REVIEW 

Emergency Response Project 

The emergency response project is one of the handling of emergency situations 

that are motivated by the need for construction work with a priority level of speed and 

accuracy of work that is urgent due to infrastructure damage that can interfere with 

activities and concerns the safety of the community. According to Institutional 

Regulation Number 13 of 2018 concerning the Procurement of Goods/Services in 

Handling Emergency Situations, a situation can be said to be an emergency in the event 

of a disaster or search and rescue operations. 
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Analysis Pareto 

Analysis Pareto is done by selecting several tasks from many problems. Based 

on Pareto's law, 80% of the total costs are selected as 20% of the causes. 

Project Scheduling  

According to Husen (2010), scheduling is one element of the planning results, 

which can provide some information in the project such as costs, labor, tools, materials, 

as well as knowing the duration of the project and the progress of time to complete the 

project. So that scheduling can be used efficiently, in its manufacture, it uses technical 

methods or methods that have been used. 

Critical Path Method (CPM) 

The CPM method is a method whose activity lies on the arrow line, namely 

Activity On Arrow (AOA). There dummy which means a pseudo activity that does not 

require time and money. The CPM method is also known as the critical path, which is a 

path with a series of each component of its activities having the longest total amount of 

time and the fastest project completion period (Soeharto, 1999). The following is a 

framework for the CPM method: 

 

 

 

Figure 1. CPM Framework 

In a CPM schedule, the factors that are determined are: 

1. ES (Earliest Activity Start Time), the earliest time to start an activity. 

2. EF (Earliest Activity Finish Time) is the earliest finish timefor an activity. 

3. LS (Latest activity start time), the latest time allowed to start an activity. 

4. LF (Latest activity finish time), the slowest time to be able to complete an 

activity. 

5. T, the required duration of an activity. 

The constraint used in AOA is that FS (Finish to Start) is equal to 0, which means 

that the next job can only start after the previous job is finished. The critical path can be 

obtained by the following steps: 

1. Forward pass 

 Activity 

Duration (T) 

Past  
Events 

Following 
Events 

ES 

LS 

EF 

LF 
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EF(ij) = ES(ij) + T(ij)  

For all activities (ij) defined, information: 

EFi =erliest start time to all activities originating from the event i. 

T(ij) = time duration of the activity from event i to j 

Where for the initial ESi is always 0. 

2. Backward pass 

LS(ij) = LF(ij) – T(ij) 

For all activities (i, j) defined, information: 

LFi =latest completion timefor all activities originating from event i. 

An activity (i, j) is on a critical path if the activity satisfies the following three 

conditions: 

ES = LS 

EF = LF 

EF – ES = LF – LS = T 

Precedence Diagram Method (PDM) 

PDM method is a method whose activities are written with nodes and arrows to 

show the dependencies of each activity, so it is also called Activity On Node 

(AON).According Hendriputri (2018) in PDM there are overlapping activities. The 

following is an example node of a PDM activity : 

No. Activity 

EST 

Type of Activity 

EFT 

LST LFT 

Duration 

Figure 2. Node PDM Activity 

Description: 

ES = Earliest Start, the earliest activity start time 

EF = Earliest Finish, the earliest activity completion time 

LS = Latest Start, slowest activity start time 

LF = latest Finish, activity completion time at the latest 
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PDM has a logical dependency relationship that varies. There are 4 types of 

relationship between two activities in PDM, namely: 

1. FS (Finish to Start), is a relationship where an activity can be started after the 

previous activity is completed. 

 

Figure 3. Finish to Start (FSn) 

2. SS (Start to Start) relationship, is a relationship where an activity can be started 

when the previous activity started. 

 

Figure 4. Start to Start (SSn) 

3. FF (Finish to Finish) relationship, is a relationship where an activity is 

completed after the previous activity is completed. 

 

Figure 5. Finish to Finish (FFn) 

4. SF (Start to Finish) relationship, is a relationship where an activity is finished 

when the previous activity started. 

 

Figure 6. Relationship Start to Finish (SFn) 

In scheduling using PDM calculations can also be based on 2 types, namely: 

1. Forward pass 

This calculation results in ES, and EF within the project completion period, if 

there is more than one activity combined then it is selected The biggest ES. For the 

notation (i) is the previous activity (predecessor) and (j) the activity being reviewed. 
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Initial time is considered zero. According to H. Kurzner (1976), to find ES and EF 

applies: 

Activity relationship finish to finish 

EFj = EFi + FFij ES j = EFj – Dj 

Relationship activity finish to start  

ES j = EFi + FSij EFj = ES j + Dj 

Activity relationship start to start 

ES j = ESi + SSij Efj = ES j + Dj 

Relationship of activities start to finish 

EFj = ESi + SFij ES j = EFj – Dj 

2. Backward Pass 

This calculation produces LS, LF and float period, if any more than one activity is 

combined then select the smallest LS. For the notation (i) is the activity being reviewed 

and (j) the next activity. To find LS and LF then apply: 

Relation of finish to finish 

activities Lfi = LFj – FFij LSi = LFi – Di  

Relationship of activities finish to start  

Lfi = LSj – FSij LSi = LFi – Di 

Relationship of start to start activities 

LSi = LSj – SSij LFi = LSi + Di  

Relationship start to finish activities 

LSi = LFj – SFij LFi = LSi + Di 

Microsoft Project 2019 

Microsoft Project is software that can be used in project management to provide 

convenience and help in planning and controlling. Its versatility helps in managing 

projects more effectively and efficiently. 

 

3. RESEARCH METHODOLOGY 

In the research, preparations were made in the form of a literature study on the 

topic of discussion. For further identification and limitation of problems and collecting 

data, where the data obtained in the form of primary and secondary data will be 

processed data with the following stages: 



 Della Ayu, et al … Analysis of Scheduling 59 
 

1. Determining activities based on Pareto law where for each activity it is necessary to 

know the percentage of costs. Then a ranking is made from the largest to the 

smallest, the number of activities containing a cost of 80%. It is checked that the 

number of selected activities must be 20% of the total number of activities. 

2. Determining the duration for each work item is obtained from the S-curve or volume 

comparison (RAB) and work productivity, where productivity can be obtained 

through field observations, implementation methods, and also interviews.  

3. Analyze dependency relationship: 

 For Precedence Diagram Method (PDM), namely start to startt (SS), start to 

finish (SF), finish to finish (FF), and finish to start (FS) based on interviews. 

 The Critical Path Method (CPM) is finish to start (FS). 

4. Processing the data so that project scheduling is obtained in the form of a Network 

Diagram using the Critical Path Method and Precedence Diagram Method with the 

help of Microsoft Project 2019 

5. Obtaining the critical path to the total project duration from both methods. 

The flow of the research carried out can be seen in Figure 7 below:  

 

Figure 7. Flow Chart of Research Methods 
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4. RESULTS AND DISCUSSION 

Perform a pareto analysis of the recapitulation data of the list of quantities and 

prices of project work based on the Bill of Quantity (BoQ). The data will be ranked 

from the largest to the smallest as in Table 1 and then a graph is made to find out 

activities that contain costs of 80%. So that the results of the analysis of activities used 

are division 7 structure and division 1 general 

Table 1. Job Ranking Based on Pareto Analysis 

 

 

Graph 1. Pareto Analysis 

Determining the duration of each work item based on the reference to the S-Curve 

and analyzing the dependency relationship to get the sequence of activities from the 

start of project work to completion of both methods. The duration and dependency 

relationship can be seen in Table 2: 

 

 

No Weight Price Each Division Cumulative Weight

Division ( % ) (Rupiah) ( % )

1 DIVISION 7. STRUCTURE 62,54% 6.082.226.146,65    62,54%

2 DIVISION 1. GENERAL 30,63% 2.978.571.209,69    93,17%

3 DIVISION 6. ASPHALT PAVEMENT 4,29% 417.514.838,81        97,46%

4 DIVISION 5. GRAINED PAVEMENT 1,22% 119.112.126,57        98,68%

5 DIVISION 3. EARTHWORKS AND GEOSYNTHETICS 0,85% 82.321.959,47          99,53%

6 DIVISION 9. DAILY WORK AND OTHERS 0,40% 39.159.561,87          99,93%

7 DIVISION 8. BRIDGE REHABILITATION 0,07% 6.599.974,91             100,00%

Job Description
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Table 2. Duration and Dependency Analysis of the CPM and PDM Methods 

 

 

After determining the duration and dependency relationship, then the existing data 

is processed into a schedule using Microsoft Project 2019 where the steps are as 

followsfollowing: 

1. Activate the software then select Blank Project to start a new job 

2. Set the total working hours and total working days, click the File menu > 

Options > Schedules 

3. Enter the project start date by clicking the Project menu > Project Information > 

Project Information Dialog > Schedule From > Project Date  

4. Compile work calendar, click Project > Change Working Time > Works Week > 

Details > Select working day > Determine working hours each day 

5. Enter work items in the Task Name and set indents and outdents 

6. Enter Predecessors 

7. Displays Network Diagram as shown in Figure 8 and Figure 9, click View > 

Other View > More View > Ne twork Diagram  

No. Job

Division 1. General

1 1.1 Mobilization A1 1,00 Ls 14 Start FS0

2 1.2 Traffic Management and Safety A2 1,00 Ls 115 A1 SS+5

3 1.3 Temporary Bridge A3 1,00 Ls 14 A1 FS0

Division 7. Structure 

4 7.1 Demolition of Concrete B1 48,60 M2 7 A3 FS0

5 7.2 Provision of steel piles diameter 500 mm thick 12 mm B2 386,50 M' 14 A1 FS0

6 7.3 Steel sheet piles, provision and erection B3 547,20 M2 7 A1 FS0

7 7.4 Transportation of bridge materials provided by service users B4 106897,60 Kg 14 A1 FS+4

SS+7

FF+4

9 7.6
PDLT (Pile Dynamic Load Testing) type dynamic loading testing 

on poles of size / diameter 500 mm
B6 2,00 Unit 1 B5 FS+1

10 7.7 Concrete, fc'= 10 Mpa B7 66,87 M3 5 B5 FS+3

11 7.8 Concrete structure, fc' = 30 Mpa B8 317,39 M3 10 B7 FS+4

12 7.9
Synthetic elastomeric placement size 460 mm x 410 mm x 

112mm
B9 4,00 Unit 2 B8 FS+4

13 7.10 Reinforcing steel fins BjTS 420A B10 47843,07 Kg 30 B11 FS0

B4 FS+10

B9 FS0

15 7.12 Plain reinforcing steel BjTP 280 B12 2623,98 Kg 7 B10 FS0
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18 7.15 Foundation of Piles, provision and erection B15 400,00 M' 2 B12 FS0

19 7.16 Masonry demolition B16 14,06 M2 4 B10 FS0

20 7.17 Masonry B17 62,78 M3 10 B15 FS0

21 7.18 Bridge nameplate B18 2,00 Unit 1 B17 FS0

7 B2

14 7.11 Installation of steel truss bridges provided by service users B11 104491,60 Kg 2

8 7.5 Erection of steel piles diameter 500 mm B5 386,50 M'

ConnectionNo.
Job Name

Code Volume Unit
Duration 

(day)
Predecessor
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8. Displaying the critical path, click Gantt Chart > Bar Styles > Critical Tasks 
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Figure 8. Network Diagram CPM 
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 Figure 9. Network Diagram PDM 

Based on the results of scheduling analysis on the Salim Mataraman River Bridge 

Replacement Project with the help of Microsoft Project 2019 it was found that the CPM 

method can carried out for 129 days starting from January 20, 2021 and ending on May 

29, 2021, the same results are also obtained from manual calculations. As for the PDM 

method, the project can be carried out for 120 days starting from January 20, 2021 and 

ending on May 20, 2021 with the same results obtained from manual calculations. After 

scheduling the two methods, it can be seen that they do not have much difference in 

duration. This can happen because the differences in the constraints on the CPM and 

PDM methods are only for some jobs.  

The use of Microsoft Project 2019 in this schedule is very helpful in the 

manufacturing process but also has some limitations, namely not being able to change 

the work code according to the data, for the network diagram display the CPM method 

does not use arrows but in the form of nodes. Then for the PDM method it does not 

show start and finish activities whose duration is zero, this is what makes the critical 

path difference between the use of Microsoft Project which only displays some critical 

activities compared to manual calculations on the PDM method. On the critical 

trajectory, it is also seen that traffic management and safety work is always in the 

critical trajectory of the two methods, because this work lasts until the end of the project 

work. Therefore, the duration of the work can be determined at the end following the 

entire duration of the project by calculating backwards (backward pass), so that later 2 

critical paths will be obtained. 
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5. CONCLUSION 

Based on the problems and discussions, the following conclusions were drawn: 

1. The results of the scheduling analysis on the Salim Mataraman River Bridge 

Replacement Project assisted by Microsoft Project 2019 found that the project 

CPM method can be done for 129 days and the project PDM method can be done 

for as long as 129 days. 120 days so that the PDM method of total duration of 

work is faster and suitable for scheduling construction projects. 

2. There are two critical paths in each method due to traffic management and safety 

work working throughout the Salim Mataraman River Bridge Replacement 

Project.  
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